Abstract

This document is designed for administrators and high level users who will be configuring security and other advanced options in XrayVision® version 4.0.
## REVISION HISTORY

<table>
<thead>
<tr>
<th>Revision Level</th>
<th>Revision Date</th>
<th>Description of Revision</th>
<th>Effective Date</th>
<th>Revision Author (Initials)</th>
<th>Approver(s) (Initials)</th>
<th>Doc Change Task#</th>
</tr>
</thead>
<tbody>
<tr>
<td>DRAFT</td>
<td>05/05/2014</td>
<td>Draft</td>
<td>NA</td>
<td>KM</td>
<td></td>
<td></td>
</tr>
<tr>
<td>1.0</td>
<td></td>
<td>Initial Release</td>
<td>05/28/2014</td>
<td>BT</td>
<td></td>
<td>283</td>
</tr>
</tbody>
</table>
# TABLE OF CONTENTS

Revision History ........................................................................................................................................ 2
Table of Contents .................................................................................................................................... 3

1 USER PERMISSIONS ............................................................................................................................ 4
   1.1 User Login and Permissions Window ............................................................................................ 4
   1.2 Active Directory Integration .......................................................................................................... 5
   1.3 Standard User Accounts and Admin Account Setup ................................................................. 8

2 SECURE LOGGING & AUDIT TRAIL FUNCTIONS ............................................................................. 17
   2.1 Secure Logging ............................................................................................................................. 17
   2.2 Audit Trail Logging ......................................................................................................................... 20

3 DATABASE MANAGEMENT .................................................................................................................. 23
   3.1 Advanced Database Utilities ......................................................................................................... 23
   3.2 Multiple Database Support ........................................................................................................... 26
   3.3 Importing a Patient from another Avertyx Database ..................................................................... 29

4 CUSTOMIZING LAYOUT DEFINITIONS .............................................................................................. 31
   4.1 Overview of the 'Layout Definition' Dialog Box ............................................................................ 31
   4.2 Layout Options ............................................................................................................................... 33
   4.3 Common Layout Tasks: Changing the Capture Order ................................................................. 34
   4.4 Common Layout Tasks: Changing the Capture Source ............................................................... 34
   4.5 Common Layout Tasks: Adding and Removing Tiles ................................................................... 35
   4.6 Common Layout Tasks: Duplicating Existing Layouts ................................................................ 36

5 ADVANCED SOFTWARE OPTIONS .................................................................................................... 38
   5.1 Options - The 'Patient' Tab ............................................................................................................ 38
   5.2 Options - The 'Image' Tab ............................................................................................................. 40
   5.3 Options - The 'Safety' Tab ............................................................................................................ 42
   5.4 Options - The 'Database' Tab ....................................................................................................... 43
   5.5 Options - The 'Sync' Tab .............................................................................................................. 45
   5.6 Options - The 'Notifications' Tab ................................................................................................. 46
   5.7 Setting up Default Options for all Computers ............................................................................. 46

6 HARDWARE OPTIONS .......................................................................................................................... 48
   6.1 The Sensors Tab ............................................................................................................................ 48
   6.2 The Imaging Devices Tab .............................................................................................................. 49
   6.3 Direct Capture Devices .................................................................................................................. 50
   6.4 TWAIN Devices ............................................................................................................................ 51
   6.5 Foot Pedal Options ....................................................................................................................... 52
1 USER PERMISSIONS

By default, XrayVision® does not put restrictions on what users can do within the program. However, through the User Login and Permissions Options, administrators can prevent certain users from performing specified functions. This is achieved through an administered user list, or integration with Windows® Active Directory.

1.1 User Login and Permissions Window

To access the user permissions options, select Tools > User Login and Permissions… The “User Login and Permissions Options” window will display.

In the “Options That Require Permissions” window, placing a check mark next to one of the functions will prevent it from being used by anyone that does not have permission to do so. If an operation is not selected in this box, it will be functional for all users, regardless of their individual account restrictions.

These commands are discussed in the next section of the guide. Assigning permissions to specific user accounts is discussed in section 1.2 for Active Directory and 1.3 for standard accounts.

1.1.1 Permission-Restricted Functions

The following operations are described for users that have been granted permission to use them.
- **Calibration Management**: Allows users to create, save, and apply calibration factors to images for use with the “Measurements” label utility.

- **Capture Images**: Gives the user the ability to acquire images from any available hardware(s).

- **Data Correction**: Allows the user to change information in a patient’s record (i.e. Name, Date of Birth, etc.)

- **Exporting/Copying Images**: Allows the user to copy images to the computer’s clipboard, or send images out of the software using one of XrayVision’s exporting options.

- **Image Deletion**: Allows users to delete images within a patient record, or delete the entire patient record from the XV database.

- **Importing Images**: Allows users to import images into XrayVision from a specified Windows directory.

- **Printing Images**: Allows users to print images directly from the XrayVision program.

- **Saving Modified Images**: Allows a user to save any modifications that they make to an image file in the program. Modified images will be permanently saved in the patient’s file.

### 1.2 Active Directory Integration

There are two ways that user accounts can be managed in XrayVision: Windows Active Directory integration, or an administered “Standard Accounts” user list. If the Active Directory option is used to assign permissions to users, those permissions will supersede any permission settings that are created in the standard accounts list.

The “Default Administrator” account in the Standard Accounts list will still be used with an Active Directory integration to access the program preferences and user login options dialog if the user that is logged in does not have permission to do so.
1. Check the “Integrate with Active Directory” box to begin configuring permissions.

2. Check the “Re-authentication is required for options that require permissions” box, if desired. This will require the logged in user to re-enter their credentials each time they attempt to perform an action requiring special permission. The following options are available for re-authentication:

   o **Authenticate using Active Directory**: Will re-authenticate using AD credentials.

   o **Authenticate using general Smart Card**: Authenticates through the use of a Smart Card reader.


3. Checking the “Restrict application startup to specified groups” box will allow you to give specific DN groups the ability to launch XrayVision in the “Group Permissions” dialog (discussed below).

4. The “Require authentication to start the program” option will also require the logged in AD user to re-enter their credentials upon launching the application.

1.2.1 **Group Management**

1. To begin adding groups to the AD Integration, click on the **Add Group** button under the group window.

![Add Group](image)

The “Group Permissions” window will display.
2. In the “Group DN” text box, enter the Distinct Name of the AD group that you wish to add to the list. Format Example:

'CN=SomeGoupName,CN=Users,DC=SomeDomain,DC=SomeDomainExt'

3. In the “Group Name” field, enter a descriptive name for the group being added. (Note: This field can be left blank. The descriptive name shows up in the ‘Group Name’ field in the list of groups.)

4. In the “Permissions” window, check the functions that you wish to give the users in this group permission to perform. Note that the additional options “Access Application Preferences” and “Start Application” are listed in this window as well. If the “Restrict application startup…” option was checked, select the “Start Application” option to give the group permission to launch XrayVision. Checking the “Access Application Preferences” will give the group permission to open the XrayVision options interface (Tools > Options).

5. Click OK when you are finished setting permissions. The group will now be added to the list. If the group has permission to perform an action, the word “Yes” will be displayed under that function’s heading in the group list window. If “No” is displayed, the group members do not have permission to perform that action.

6. The Edit Group button will allow you to adjust permissions settings for groups that have already been added to the list. (Note: You can also change the descriptive name of the group but you cannot change the Group DN.)

You can give multiple groups the same permission settings by holding CTRL and left clicking on them in the list before choosing the Edit Group operation. This method also works to delete multiple group entries from the list at the same time (discussed below).
7. If you click the **Copy Current User Info to Clipboard** button, the Distinct Name of the user that is currently logged in to the computer, as well as the DN of that user’s group will be copied to the computer’s clipboard. You can then paste that information into any text control or document for quick reference.

![Copy Current User Info to Clipboard](image)

8. The **Delete Group** button will delete any selected group(s) in the list. After clicking the button, you will receive a dialog box asking you if you are sure that you want to remove the selected group(s) from the list. Click **Yes** to continue.

![Delete Group](image)

### 1.3 Standard User Accounts and Admin Account Setup

The **Standard Accounts** list is another way of managing user permissions in XrayVision. It involves creating user names and passwords specifically for XV functionalities. By default, this list only contains a disabled administrator account. When enabled, this “admin” account’s credentials are used to access program preferences, user permissions options, and securing logging/audit trail settings. For more information about setting up the administrator account, see section 1.3.1.

![User Permissions](image)

There are several options in the standard accounts section of the "User Login and Permission Options" window:

- **Base User IDs in the Window’s Logon User Name:** This option will automatically populate the “User ID” field of the login window with the current Windows user’s login name.

- **Display Asterisks for Entered User IDs:** If this option is checked, entries in the user ID field will be masked with the “*” symbol. Passwords are permanently masked by default.
**Require a User to Login at Application Startup:** This option will require any XrayVision user to log in to the program when it is launched. If a user does have credentials to use XV, it will restrict them from performing ANY task and they will be forced to close the program.

- **Associate the User Login with Acquired Images:** This option will show the user login name within Audit Trail log files. For more information about Audit Trail functionality, please refer to section 2.2.

### 1.3.1 Configuring the Admin Account

1. Double click on the “admin” user in the user list. The “User Permissions” window will appear.

2. Deselect the “Disable this user” option (highlighted in red above)

3. Click **OK**. The admin user is now active. In order to access the program preferences (*Tools > Options*), user permissions, and secure logging/audit trail options, the “admin” username and password must be provided. The default password for the admin account is “AKRON”.

4. To change the admin password, highlight the “admin” user in the user list and click the **Change Password** button.

5. The “User Password” dialog box will then display. Enter the default password (AKRON) in the “Old Password” field, and set the new password in the corresponding boxes.
6. Click OK. The password will now be updated for the admin user. (Note: Passwords are case sensitive.)

If at any point the administrative password is lost and you are unable to access options in the program, please call Aptyrx technical support for assistance (877-APTERYX).

1.3.2 User Setup

XrayVision users can be added to the account list in various ways. They can be created individually, through coordination with domain user groups, or by being imported from a file.

1.3.2.1 Individual User Creation

1. To manually add an individual user to the accounts list, click on the Add User button under the list window.

2. The “User Permissions” window will display. Enter the appropriate data into the user ID and user name (optional) fields. If the admin user is manually assigning passwords to user accounts, they can do so by filling in the password fields in this window as well. (For more information about setting passwords, please refer to section 1.3.3 below.)
3. Select the operations in the “Permissions” window that you wish to give the user the rights to perform. The “Disable this user” option can be used to suspend an account’s access to the program without deleting it from the list.

4. Click OK when you are finished. The new user account will be added to the accounts list.

### 1.3.2.2 Coordinating Names With A Domain

Although users created using this utility are coordinated with a group in the domain, these users do not authenticate against the domain. This utility simply allows usernames contained in a domain group to be imported and permissions set in bulk.

1. To add user names to the list from a pre-defined domain group, simply click the Coordinate Names With A Domain button.

2. The “Domain and User Group” window will display. Enter the appropriate domain and user group names into the text fields.
3. Click OK. A list of all the users that belong to the specified group will display in a new window. Review the information to verify that the appropriate users will be imported into the list and click OK.

4. If there were any user accounts in the list before the coordination (other than the default “admin” account), they will be displayed in a new window. If you wish to remove these accounts, click OK. If you would like to leave the accounts in the user list, click Cancel.

5. In the “User Permissions” window, select the appropriate functions that the users in the group should have access to. Click OK when finished.

6. The new user names will be added to the accounts list. “Yes” or “No” will be displayed under the various function headings in the list to reflect whether or not that user has permission to perform it.

1.3.2.3 Importing Users From a File

Users can also be added to the accounts list by importing them from a file. The files must be saved in a plain text format (.txt, .csv) and have a single column of user names for proper importation.
1. To import users from a file, click the **Import Users From File** button under the accounts list window.

   ![Import Users From File button](image)

2. A list of all the users that belong to the specified group will display in a new window. Review the information to verify that the appropriate users will be imported into the list and click **OK**.

3. If there were any user accounts in the list before the import (other than the default “admin” account), they will be displayed in a new window. If you wish to remove these accounts, click **OK**. If you would like to leave the accounts in the user list, click **Cancel**.

4. In the “User Permissions” window, select the appropriate functions that the users in the group should have access to. Click **OK** when finished.

5. The new user names will be added to the accounts list. “Yes” or “No” will be displayed under the various function headings in the list to reflect whether or not that user has permission to perform it.

### 1.3.2.4 Editing, Deleting or Disabling User Accounts

User accounts can be edited or deleted from the list at any time.

**To edit an account:**

1. Select the user account in the list and click on the **Edit User** button.
   (Note: Multiple accounts can be selected for editing if they are going to share the same permissions. However, user names must be edited one account at a time.)
2. When the “User Permissions” window displays, change the appropriate values and click **OK**.

3. Any changes should now show under the various permissions headings in the account list.

**To delete a user account from the list:**

1. Select the user account and click the **Delete User** button. (Note: Multiple user accounts can be selected for simultaneous deletion.)

   ![Delete User](image)

2. Click **Yes** in the confirmation dialog box if you wish to continue with the deletion of the account(s). The account(s) will be removed from the list.

   ![Info](image) As an alternative to permanently deleting a user’s account, the admin user can “Disable” it. This will suspend the use of the account, but retain all of its configurations. To disable an account, double click on it in the list and check the “Disable this user” option under the confirm password field. The account can then be re-enabled at any time by unchecking the option.

### 1.3.3 Password Configuration

User passwords in XrayVision can be set in different ways. One way is to allow the user to set their own password. Another would be to manually assign a password to an account through the login and security options. Passwords can be changed or reset at any time by the admin user. The administrator can also adjust settings to control the length and strength of the password text.

#### 1.3.3.1 User Defined Passwords

To allow users to create their own passwords:

1. Highlight all of the created user accounts in the list (except for the “admin” account).

2. Click on the **Reset Password** button below the account list window.

   ![Reset Password](image)

3. Verify that you want to reset the password for the selected account(s) when the window displays.
4. The first time that a user logs in to XrayVision, have them enter their User ID but leave the “Password” field blank. They will then be prompted to change their password when they click OK.

5. The “User Password” dialog box will appear. Since their initial password is blank, they can leave the “Old Password” field empty. Once they create and confirm their password and click the OK button, it will be set for their account. (Note: Passwords are case sensitive.)

1.3.3.2 Admin-Defined Passwords

An admin user also has the option of setting a user’s password for them. To manually set a user’s password:

1. Highlight the user’s account in the “Permissions Options” list.

2. Click the Change Password button below the list window. The “User Password” window will display.
3. If there was a password previously set for the user's account, enter it in the "Old Password" field. If the account was just created, this field can be left blank.

   ![Password Change Dialog]

   If a password was previously set for the user's account but it is not known by the admin user, it will need to be reset by clicking on the Reset Password button under the user list. This must be done before the password change will be accepted. If a password is reset, the simply leave the "Old Password" field blank when setting the new password.

4. Enter and confirm the new password in the required fields and click OK. The user's password will now be updated.

### 1.3.3.3 Password Policies

The password policy settings allow the admin user to adjust the required strength of a user's password. Settings can be adjusted individually, or preset values can be entered by selecting Low, Medium, or High in the "Quick Security Settings" section (highlighted in green below).

![Password Policies Image]
2 SECURE LOGGING & AUDIT TRAIL FUNCTIONS

Secure Logging allows administrators to view reports of the various activities performed by users (i.e. capturing and deleting x-rays) within the XrayVision program. The reports are saved in a folder called “Logs” in the XV application directory (usually located on the server machine). Any user that has access to that folder will be able to access and read the logs.

Audit Trail reports also allow admin users to view what actions a user is taking, but the communications can be stored in a separate folder (or even on a separate machine) with restricted permission settings so that unauthorized users cannot access or edit them.

2.1 Secure Logging

2.1.1 Secure Logging Setup

To enable the secure logging functionality:

1. Click on Tools > Securing Logging and Audit Trail > Secure Logging And Audit Trail Options… (Note: If the “admin” user account is enabled, you will be prompted to enter the admin password before accessing the options. See section 1.3.1 for more information.)

2. The “Secure Logging Options” window will display. Click the checkbox next to “Enable secure logging” to turn logging on.

3. In the “Keep log files for” field, enter the appropriate amount of time that you wish to keep log files in the XrayVision folder. As an alternative to setting a time period, you can specify a certain number of logs to be kept by changing the drop down field to “total logs”.

2.1.2 Accessing & Analyzing Secure Logs

To access secure log files:
1. Click **Tools > Secure Logging And Audit Trail > View Logs...** (Note: If the “admin” user account is enabled, you will be prompted to enter the admin password before accessing the options. See section 1.3.1 for more information.)

2. The “Log Viewer” window will appear. This window will display a date tree on the left side, allowing users to drill down to a specific date and time.

3. The log file’s name format is as follows:

   ```
   ComputerStationName_Date(YYYYMMDD)_Time(HHMMSS).Slog
   ```

   Click on a log file to view the actions that were taken during that session. (Note: The newest log in the list will always be locked, as it is recording the actions taken in the current session. To view the contents of that log you must close and re-launch the software.)

4. The contents of the selected log file will display in the right hand portion of the window.
5. The example log file above displays various pieces of information about the software and the computer that is accessing it. The “Windows Login Users Name” is the name of the Windows authenticated user using the station. The “Logged in user” is the name of the user account that logged in to XrayVision when the software was launched.

6. In addition to the various lines of diagnostic information, the fields highlighted in green above reflect actions taken by the logged in user. In this case, the “Admin” user created a patient in XrayVision named “Patient, Test”, captured a single image under the patient’s record, and closed the program.

7. Any log can be exported out of XrayVision as a plain text file by highlighting it in the list and clicking on the Export button in the bottom right of the “Log Viewer” window.

8. Select the desired save location and name for the log file and click Save. You will now be able to view the logged activities in any text editing program.

Warning: Secure Logging files are saved in XML format in the “Logs” folder of the XrayVision install directory. Any user that has full access to the XML folder will be able to open the “Logs” folder and view, edit, or delete entries. If stronger security for logging entries is desired, Apteryx recommends using both the Secure Logging AND Audit Trail functionalities. An Audit Trail server component can be configured to run in a remote location with different permissions settings to avoid unauthorized access.
2.2 Audit Trail Logging

In order for XrayVision’s Audit Trail functionality to work properly, an Audit Trail server component must be installed and configured on a machine that is able to receive network communications from all XrayVision workstations.

Audit Trail is a logging feature that is used to log every action performed in the XrayVision application. Audit Trail logs are stored in the location specified on your Audit Trail server during the server component configuration.

2.2.1 Setting Up Audit Trail in XrayVision

To enable Audit Trail logging within XrayVision:

1. Click **Tools > Secure Logging And Remote Audit Trail > Secure Logging And Remote Audit Trail Options** (Note: If the “admin” user account is enabled, you will be prompted to enter the admin password before accessing the options. See section 1.3.1 for more information.)

2. The “Secure Logging Options” window will display. Click the checkbox next to “Enable audit trails” to enable the Audit Trail options.

3. In the “Audit Trail Server IP Address” field, enter the IP address of the machine that is running the Audit Trail server component.

4. The “Audit Trail Server Port” field contains a default value of 7663. If a different port was specified for communication when the Audit Trail server component was configured, enter the appropriate port number in this field.

5. The “Audit Trail ID” field can be left blank, or you can enter a descriptive name for the current computer that will display in the audit logs.

6. Click the “Show audit trail communication window” option if you wish to display an Audit Trail status box (shown below) when XrayVision is launched. The communications box will show a server connection status, an audit trail packets queue status, and some general information about the logged in user and their actions (updated in real-time).
7. Click OK when you are finished. The Audit Trail logging will now be enabled on all workstations.

8. If there is an interruption or disconnection between the Audit Trail Server and the XrayVision workstation, an error message similar to the one shown below will display:

![Error Message]

When troubleshooting the connection, always make sure that the Audit Trail Server component is running on its home machine.

### 2.2.2 Viewing Audit Trail Logs

Audit Trail files are saved in basic text (.txt) format and can be opened in any text editing program. (Note: Notepad or another non-text wrapping editor usually works best due to the number of columns in the log.) The file name format is as follows:

```
SERVERNAME_AUDITTRAIL_DATE(YYYYMMDD)_TIME(HHMMSS).TXT
```

1. Open the appropriate file for viewing.

2. General information about the logged in user and the Audit Trail server computer is displayed at the top of the file. Recorded actions are displayed in the “Audit Trail Entries” section.

3. The headings for each entry are as follows:

   - **Time:** The time and date that the recorded action took place.
   - **Computer Name:** The name of the workstation on which the action was taken.
   - **User Name:** The active Windows user name during the action.
- **XV User Name**: The user account that was logged in to XrayVision at the time of the action.

- **Local Computer IP**: The workstation computer’s local IP address.

- **WAN Computer IP**: The workstation computer’s WAN IP address.

- **Audit Trail ID**: The Audit Trail ID is a computer identifying name set when enabling the Audit Trail functionality. (See section 2.2.1 for more information.)

- **Patient Info Fields**: These fields display information about the patient that was open during the recorded action. If no patient record is open, these fields will be blank. (Name, ID, Other IDs, Sex, DOB)

- **Action**: The action field gives information about what was done in the software at that point in time. Some example messages that may appear in this column are “Capture Images”, “Edit Preferences”, “Image Modified”, etc.

- **Data**: The data column provides more information about the “action” that was taken. For example, if a “Capture Images” action was taken, the data field will show information about the image that was captured.
3 DATABASE MANAGEMENT

XrayVision image files are stored in a folder called “Patients” in the main install directory. Anytime a patient is created in the XrayVision database, a subfolder is created for them within the “Patients” folder. Any images that are taken under that patient’s account will be stored in their folder. The default naming convention for patient subfolders is as follows:

LASTNAMEFIRSTNAME_LAST4OFSS#_LAST4OFID#

If there is no social security number entered for the patient, the folder name will just add the last 4 of the ID after the name.

The naming convention of patient subfolders can be changed to anonymize personal information. Please see section 5.1 for more information on how to change folder names.

The following sections describe some of XrayVision’s advanced database utilities, as well as how to configure support for multiple image databases.

3.1 Advanced Database Utilities

The Database menu in XrayVision contains many tools that administrative users can use to manipulate patient records. In this section, we will discuss some of the most commonly-used database utilities. For more information on any utilities not covered in this guide, please contact the Apteryx Technical Support team at 877-APTERYX (278-3799).

3.1.1 Update Patient Database

If patient subfolders or files are added directly to the “Patients” folder (by copying and pasting them from another install for example), the patient and/or files may not display in the XrayVision interface. In order to get the records to appear, a database index update is required.

The Update Patient Database function should only be performed when all workstations have XV closed. This function will run most quickly if it is performed directly on the server, rather than being run from a workstation.

To update the patient database:

1. Click Database > Database Utilities > Update Patient Database.

2. Click Yes if you wish to continue with the update. The time that it takes for the update to complete will depend on the size of the “Patients” folder for which the database is being updated.

3. Once the update completes, the new patient records/images should display in any “Open Patient” interface within XrayVision.

3.1.2 Advanced Patient Merge

When duplicate patient records are created in XrayVision, users have the ability to merge them into one single record. However, if there are a large number of duplicates in the database, going through and merging them one at a time can be a time consuming
process. The advanced patient merge tool will scan the Apteryx database and attempt to match patient records that need to be merged together based on a set of user-defined criteria.

To use the advanced patient merge utility:

1. Click **Database > Database Utilities > Merge Patients > Advanced Patient Merge.**

2. The “Advanced Patient Merge” window will display.

3. There are 5 sets of criteria that can be used to find duplicate patients to be merged. Each checkbox option contains a description of what the database scan will do when attempting to find matching patients. Select the desired criteria set(s) to be used for the merge.

4. Under the “When merging patients together, they should be placed under” option, select the appropriate patient entry for duplicates to be merged into. The “Oldest Patient Entry” options will combine all found duplicates into the patient’s record that was created FIRST in the XrayVision database. The “Newest Patient Entry” will combine duplicates into the record that was created most recently.

5. The “When checking SS/ID, use the patients:” option defaults to use the patient’s ID number when checking for duplicates. This is because all records created in the XrayVision database should have ID numbers, but SS#’s may not be provided for each patient. However, you can change this field to check using the SS# if you so choose.

6. Click **OK** to begin the database scan. Once the scan completes, the “Advanced Patient Merge TODO” window displays.
7. This window will display any potential merges that the database scan found based on the entered criteria. The resulting patient record (if the merge is continued) is displayed in bold text. The current records that will be merged into the resulting record are listed in smaller text underneath.

8. You can left click on any match in the TODO window to disable those particular records from being merged. A grey X icon (below) will show up next to the potential merge if it has been disabled. You can also "Disable All" or "Enable All" merges by clicking on the appropriate buttons at the bottom of the window.

9. The Print button at the bottom of the TODO window will allow you to print a list of the records that will be merged by the utility before it is run. A printout may aid you in the case that a patient record is merged accidentally when it is not supposed to be.

10. Click the OK button when you are ready to begin the patient merge. If you chose not to print a list of the patients to be merged, you will receive a prompt stating that no report was printed. If you wish to begin the merge anyway, click Yes.

11. Read the dialog in the WARNING! message box that displays. If you would like to continue the merge, click Yes.

12. XrayVision will now merge the records that were selected in the TODO window. The time it takes the merge to complete will depend on the size of the merge list. You will be returned to the XrayVision desktop when the merge is complete.

3.1.3 Restoring an Original Image

There may be times that unwanted enhancements, or other changes, are made to an image and that image is accidentally saved in the database. If the “Archive the original image so it may be recalled later” option is set in the “Safety” Tab of the XrayVision
preferences (discussed in section 5.3), an original copy of the image was saved before the edit. These files are stored in a folder called “Original Images”, which resides within the specific patient’s database subfolder.

The Patient Utilities menu in XrayVision provides a tool to restore the original, unchanged image. To restore an original image:

1. Open the edited image on the XrayVision desktop.
2. Click Patient > Patient Utilities > Restore Original Image.
3. You will receive the message above. Click Yes to restore the original image file.
4. The image will close during the restoration process. You can now open the restored image from any “Open Image” interface.

Original images can also be restored by copying them from the “Original Images” folder within the patient’s subfolder and overwriting the “bad” files in the parent folder. If this method is used, the “Update Patient Database” utility (covered in section 3.1.1) may need to be run for the new image(s) to display properly in XrayVision.

### 3.2 Multiple Database Support

XrayVision can be configured to support multiple database instances. If, for example, there is more than one doctor at the same dental clinic, they can each create their own patient database. Users can then select which database they want to use when capturing and viewing images.

Once more than one database is configured for use in XrayVision, you can enable a prompt that will ask the user which database to use when the software is first opened. That preference is found under the “General” tab of the XrayVision options. In the “Startup Actions” section, enable the “Prompt for which database…” option to enable it.

#### 3.2.1 Creating Databases

To create a new database instance:

1. Click Database > Advanced Database > New Database
2. The “Database Information” window will display.
3. The “Name” field within this dialog is the name for the database that will be shown in the “Select Database” window, as well as in the title bar of the program when it is the active instance.

4. Information in the other fields is optional, and will only display within the “Select Database” window to help users with organization. When you have filled in the desired information, click **OK**.

5. The newly created database will become the active instance, and its name will be displayed in the title bar of the program.

6. Any patients that are created will be stored in the new database until another database instance is selected.

   Newly created databases are stored within the “XVDatabases” folder, inside of the main XrayVision install directory. Each database will have its own subfolder that functions in the exact same way as the main “Patients” folder.

### 3.2.2 Selecting a Different Apteryx Database Instance

To select a different database instance:

1. Click **Database > Advanced Database > Select Current Database**…

2. The “Select Database” window will appear.
3. This window will display any local databases that have been created, as well as any networked database associations (see step 4) that have been setup previously. To make a database instance “active”, simply click on its name and select OK. That database will become active, and display in the title bar of the program.

   Note: The “Default” database instance refers to the “Patients” folder within the main XrayVision install directory.

4. If there is an existing Apteryx Imaging patient database in a location other than the “XVDatabases” folder, click on the Browse For Databases button to browse to it.

5. The Windows explorer window will appear. Navigate to the database folder location and click Open. The remote database instance will now be active. The word “Remote” will appear in the application title bar, indicating that the current database exists outside of the main XrayVision install folder.
6. To edit the name of the “Remote” database, re-open the “Select Database” window (Database > Advanced Database > Select Current Database) and highlight the newly created instance. (Note: Until you edit the database name, the path to the database will be in the “Name” field.)

7. Click the Change Information button. The “Database Information” screen will appear.

8. Edit the appropriate information in the text fields and click OK.

9. Close the “Select Database” window. When the software is closed and re-opened, the updated database name will be displayed in the program title bar.

3.3 Importing a Patient from another Apteryx Database

If another instance of an Apteryx Imaging patient database exists, and is accessible to a workstation, a user can import a patient file and its related images using the Import Patient function. To import a patient:

1. Select Patient > Import Patient from the main menu.

2. The ‘Select the appropriate directory.’ dialog box displays. Browse to the applicable patient’s folder.
3. Click **OK**. A new patient file will be created in the current patient database.
4 CUSTOMIZING LAYOUT DEFINITIONS

A layout is a method of displaying a series of images in a single workspace. The imaging application comes equipped with pre-defined layouts that a dental practice can use to capture patient images for bitewings (2 and 4 BWXs), full mouth series, anteriors (upper and lower), etc.

Each layout has a series of free-floating tiles that are arranged to represent the anatomical location of groups of teeth in the mouth. Each tile in a layout identifies the source of the image (sensor, scanner, video, etc.), its orientation, related tooth associations, and its order in the capture sequence.

4.1 Overview of the ‘Layout Definition’ Dialog Box

The ‘Layout Definition’ dialog box is where users can customize their own layouts by creating new layouts or modifying the definitions in an existing layout to meet their needs. Select Tools > Layout Definitions from the main menu, or select the Capture Layout ( ) button on the toolbar and then click on the Edit Layout Definitions to launch the ‘Layout Definition’ dialog box.

4.1.1 The Interface

1. Existing layouts can be modified by selecting from the dropdown in the upper right corner of the window.
2. If a layout is selected, it will display in edit mode in the large preview window.
4.2 Layout Options

Users can configure general layout options when creating a new layout or editing an existing layout by selecting the “Layout Options” button.

Users can define/redefine the following in the layout properties:

- **Layout Name** – Changes the name of the layout definition when shown in any list view.
- **Inside-Out View** – Flips the entire layout’s view horizontally to simulate tooth positioning from the patient’s perspective. (Note: This option does not simply mirror all images in the layout; it also changes the position of all tooth associations within the layout as well. This means that what was represented as the left side of the mouth before is now the right side and vice versa.)
- **Background Color** – Users can select the drop-down to specify a different color for the layout background.
- **Layout Imaging Extension Preference** – This option allows the user to select an imaging device that will automatically be selected when the layout is chosen in capture mode.

### 4.2.1 Edit Menu Functions

There are a collection of commands in the “Edit” menu of the layout definition window that allow you to manipulate tiles in the layout. Some commands will not be available until a tile or tiles are selected. Refer to the table below for a quick description of each:

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Restore Tiles" /></td>
<td>Restores tiles that have been moved off the screen</td>
</tr>
<tr>
<td><img src="image" alt="Adjust Height" /></td>
<td>Adjusts height of selected tiles to equal length</td>
</tr>
<tr>
<td><img src="image" alt="Align Center" /></td>
<td>Aligns the center of selected tiles</td>
</tr>
<tr>
<td><img src="image" alt="Edit Properties" /></td>
<td>Edit layout properties</td>
</tr>
<tr>
<td><img src="image" alt="Forces Tiles" /></td>
<td>Forces tiles to align to a defined grid</td>
</tr>
<tr>
<td><img src="image" alt="Adjust Height &amp; Width" /></td>
<td>Adjusts height &amp; width of selected tiles to equal length</td>
</tr>
<tr>
<td><img src="image" alt="Align Right-Hand Edge" /></td>
<td>Aligns the right-hand edge of selected tiles</td>
</tr>
<tr>
<td><img src="image" alt="Evenly Spaces Vertically" /></td>
<td>Evenly spaces selected tiles vertically</td>
</tr>
</tbody>
</table>
4.3 Common Layout Tasks: Changing the Capture Order

Each tile in a layout identifies the source of the image (sensor, scanner, video, etc.), its orientation, related tooth associations, and its order in the capture series. To change the capture order:

1. Select the desired layout to edit. The layout/tiles display in the preview window.
2. Select the **Order** button to enable the tile ordering function.
3. Note that the current capture order of each tile displays in the top-left corner of each tile.
4. With the ordering function now enabled, click on each tile in the order desired for capturing. The tile numbers will be automatically reordered as the user clicks each tile in the series.
5. Select the **Done** button to store the changes.

4.4 Common Layout Tasks: Changing the Capture Source

Each tile in a layout identifies the source of the image (sensor, scanner, video, etc.). To modify the capture source of a layout:

1. Select the desired layout to edit. The layout/tiles display in the preview window.
2. Select the source button ( ) from the toolbar below the preview window.

3. The ‘Take From’ dialog box displays.

![Take From Dialog Box]

4. Select the desired source from the provided drop-down list:
   - **Prompt User For Source** – The user will be prompted to select a source during the layout capture process.
   - **Nowhere** – The user will not be prompted for any source.
   - **Scanner** – The layout will be setup to acquire from phosphor plate scanners, flatbed scanners, etc.
   - **Sensor** – The layout will be ready to acquire from x-ray sensors.
   - **File** – The layout will be setup to acquire images from the local hard drive, network, or media device attached to the computer.
   - **Clipboard** – The layout will be setup to acquire an image stored in the Window’s Clipboard.
   - **TWAIN Device** - The layout will be setup to acquire from devices, such as document scanners, that have the manufacturer’s TWAIN drivers installed on the computer.
   - **Video Source** - The layout will be setup to acquire from a video source, such as an intra-oral or extra-oral camera, using the DirectVideo or Real-Time Video extension.
   - **Auto-Import** - The layout will be setup to acquire using the Auto-Import utility.

   For more information about how the auto-import utility works, please refer to section 6.1.4 in the XrayVision 4 user manual.

5. Click **OK** when done.

6. Select the **Done** button on the ‘Layout Definitions’ dialog box to store the changes.

### 4.5 Common Layout Tasks: Adding and Removing Tiles

To add an additional tile to a layout:
1. Select the desired layout to edit. The layout/tiles display in the preview window.

2. Below the preview window, select ![horizontal tile](image) to add a horizontal tile or ![vertical tile](image) to add a vertical tile to the layout. Selecting the ![square tile](image) button places a square tile in the layout.

3. Refer to section 4.2.1 above for additional functions that can be performed to further configure the tile’s position as needed.

To **remove a tile** from a layout, simply left-click it and press the delete key on the keyboard.

### 4.6 Common Layout Tasks: Duplicating Existing Layouts

XrayVision gives users the ability to create a layout from scratch, or to create a new layout based on an existing layout (i.e. duplicate an existing layout). Basing a new layout on an existing one is useful if the user needs to create a duplicate layout for a different hardware extension. For example, if a user has an existing 4 Bitewing Layout that is set to capture from a sensor, a duplicate layout can be easily created for capture from their intra-oral camera. To duplicate an existing layout:

1. At the top of the layout definition window, select **Layout > New Layout**. The ‘New Layout’ dialog box displays.

![New Layout dialog box](image)

2. Enter a descriptive name for the new layout in the ‘Layout Name’ field.

3. Select a preferred imaging extension, or select "no preference" to be prompted for a source when capturing.

4. Select a background color for the layout. Using different colors for different hardware extensions can help the staff differentiate between layouts.
5. Select the existing layout to be duplicated from the ‘Based On’ drop-down menu.

6. Select the Layout Type (Static Grid or Free Floating). The static grid snaps tiles to certain locations based on a background grid system within the layout field. Free floating allows you to place tiles freely on the screen without being confined to the grid preset distances.

7. Click OK to continue. The ‘New Layout’ dialog box closes and the duplicated layout is displayed in the preview window.

8. Refer to the sections above for additional functions such as changing capture order, adding and manipulating tiles, etc. Select the Done button on the ‘Layout Definitions’ dialog box to store the changes.
5 ADVANCED SOFTWARE OPTIONS

If users are given permission to access the XrayVision preferences, they can do so by clicking **Tools > Options** on the main menu. Some of the options contained within the preferences should only be changed by a high level user or administrator of the system. The following sections detail these options and their functionalities.

5.1 Options -The 'Patient' Tab

The 'Patient' tab contains settings that pertain to patient data entry and referencing.

- **Patient Data Masking:** This option allows a qualified technician to change the naming scheme of the patients’ folders within the XrayVision “patients” directory to mask personal info. There are 3 options to choose from when masking patient directory names:
  
  - **Use Descriptive Name:** Standard Apteryx naming format. 
    (LastNameFirstName_Last4ofSS#_Last4ofID#)
  
  - **Only Include the Patient Name:** This option includes the patient’s real name but generates anonymous numbers for the last 4 of the SS# and ID#. 
    (LastNameFirstName_XXXX_XXXX)
  
  - **Totally Anonymize the Name:** This format will anonymize all of the data in the folder names. (PATIENTXXXXX_XXXX_XXXX)
• **Only Display Patient List When Search Criteria have Been Entered:** This option prevents any records from showing up in the ‘Open Patient’ rolodex until information has been entered into one of the search fields. This helps to speed up patient lookup on slower networks.

• **Automatically Scroll to the Previous Patient Index:** This option makes the ‘Open Patient’ rolodex jump to the patient’s record that was last opened in XrayVision.

• **Patient Definition Requirements:** If selected, a utility will display allowing users to define the data required to create a patient file. Additionally, the format of the required fields can be configured.

• **Automatically Sequence ID Numbers:** With this option checked, when manually creating patients in XrayVision, their ID numbers will be created sequentially based upon the last patient that was manually created.

• **Keep track of recent patients globally** – Enable this option if imaging application is installed on a network. It will make the recent patient list available to all workstations.

• **Recent Patient List Keep track of patients** - Define the amount of recently accessed patients the imaging application should keep track of. The patient files will be included on the recent patients list, an easy access list of recent patients available under *Patient > Recent Patients* of the main menu.

• **Enable Global ID Matching** – If bridging from a built-in button in the Practice Management application, this option allows the imaging application to automatically merge patient information based on the following criteria:
  
  - ID Number only
  - Social Security (SS) Number only
  - Both ID and SS Number

  **Warning:** Enable this option ONLY if the entire organization utilizes a global ID scheme for patient identification.

• **Prevent data wiping** – Option is enabled by default to avoid replacing pre-existing patient information with blank content.

  **Warning:** It is strongly recommended not to disable Prevent Data Wiping. Contact Apteryx Support at 877-APTERYX (278-3799) to learn more about the possible impact to patient data during a merge.
• **Enable patient FMap validation** - This option enables or disables the automatic update and checking of patient file maps. This option is only to be disabled on systems with significant network lag. The patient FMap needs updated anytime new images are added to a particular patient.

• **Consult Data Drills when opening patients from other applications** – If enabled, the imaging application will check the name against a practice management (PM) database for the ID number, SS number, Date of birth, and sex. The feature requires a related PM data drill installed and configured properly to work.

### 5.2 Options - The ‘Image’ Tab

The ‘Image’ tab contains setting pertaining to the display and storage of images in XrayVision.

- **‘Stamps’** – Stamps, also referred to as thumbnails, are the small icon-like copies of the original image files that display on the Patient Index, Open Patient Images, and Tooth/Teeth Related Images dialog boxes. Enabling **Use image stamp files** will create and store the small image stamp files. **Include labels in stamp images** includes any added labels in the image stamp.

- **Auto place taken date labels** – Option adds a taken date label, as shown below, when displayed on the application desktop. The label is only applied to images captured after the option is enabled.
Always use this quality factor – JPEG quality factor is an image compression technique that reduces the size of a file to save space on the hard drive. Images can be compressed by as much as 90%, however, the more an image is compressed the more image detail is sacrificed. Apteryx, Inc. recommends leaving the settings to the highest quality feasible.

Use status bar indicators on secure images - If disabled, status bar indicators will not be shown with the secure images.

Draw real representations of layouts - Displays image thumbnails or stamps of the layout as opposed to just gray boxes that represent a layout.

Use time/date format for layout tile dates – If disabled, the date displayed below layout tiles will appear in the YYYY/MM/DD format.

Automatically prompt for tooth information - If disabled, users will not be prompted for tooth information after image acquisition.

Automatically prompt for image type - If disabled, users will not be prompted to specify an image type or subtype during image acquisition.

Automatically prompt for tooth info for unassociated files – This option will prompt the user for tooth associations in the case that an image is captured into a layout and does not contain any existing tooth information.

When dragging images in layouts, automatically re-associate tooth numbers - When enabled, this option will automatically change the tooth associations of images when they are moved to different tiles within a layout.
• **Change Storage Format** – Allows users to configure the file type images should be saved in. Format options include:

  o **Apteryx 16 Bit Secure Tag Block (STB16)** – Apteryx’s proprietary 16 bit image storage format that guarantees image authenticity.

  o **Apteryx Secure Tag Block (STB 8)** – The recommended image storage format.

  o **High Quality JPEG** – The space-saving storage format that uses the highest possible quality setting. Image authenticity is sacrificed with this format.

  o **JPEG** – This option uses a lower image quality setting than the setting above.

• **Apply storage scheme to already saved images** – If this setting is enabled when the storage format is changed, any existing image in the database will be converted to the new format when resaved. The user will be prompted with a message indicating the format change when resaving images.

5.3 Options - The ‘Safety’ Tab

The ‘Safety’ tab includes options to help users minimize image loss that can be caused by loss of network connectivity, power, etc. during a file save process.
• **‘Safety Cache (TM)’** - When these settings are checked, the program will automatically save a temporary duplicate file on the hard drive. If these settings are not checked and the computer crashes or loses power, unsaved images will be lost.
  
  o **Use Safety Cache (TM)** applies to older or slower computers such as a 486 or Pentium 100. (Such systems are not recommended.)
  
  o **Use Threaded Safety Cache(TM)** – applies to most new computers.

• **Automatically save layouts/groups after each capture** - Automatically saves layouts in the patient’s file after each capture once the user clicks **Done**.

• **Check network connection before save operations** – With this feature disabled, users attempting to save a file over a network system that has been terminated may lose the file or receive an error message.

• **Allow patient access tracking** - This setting activates a patient record tracking feature that displays dates and times of the most recent activities within a patient’s file.

• **When saving modified images to a patient** – The available settings allow users to define how the software will treat modified images. Available options include archiving or overwriting the original image.

### 5.4 Options - The ‘Database’ Tab

The ‘Database’ tab contains settings that allow administrators to specify the mechanism by which patient database changes are detected over a network. The settings are dependent on the type of network setup in the dental practice.
• **None** - This setting should only be used if the practice only has a single computer for dental x-ray imaging. This setting should only be used when computers are NOT networked.

• **Database polling** – This setting applies to computers that are on a network. With this setting enabled the imaging application is responsible for monitoring the database therefore it is supported by all Microsoft® Windows® operating systems.

• **OS notification** - This setting also applies to computers that are on a network, however, with this setting enabled, the Windows® operating system (OS) is responsible for monitoring changes to the database. This setting is only supported by legacy versions Windows NT and Windows 2000.

• **Use database caching** - This option requires more memory but can significantly reduce network lag over slow or heavy networks. This option will help reduce delays when looking up patients over Wide Area Networks (WANs).
5.5 Options - The 'Sync' Tab

The 'To Store' database feature automatically adds all newly acquired and edited images to an index file called 'ToStore DB'. This feature should only be used in conjunction with XV Sync™, the remote database synchronization application created by Apteryx, Inc. for users with two (2) or more office locations. For more information on XV Sync, contact Apteryx Support at 1-877-APTERYX (877-278-3799).
5.6 Options - The ‘Notifications’ Tab

The Notifications tab allows qualified technicians to configure XML communications to a web server that watches for changes in the XrayVision database. For more information about XML notifications, please refer to our knowledgebase article at http://www.apteryx.com/kb/topics/OVERVIEW_XML_Notify.htm.

5.7 Setting up Default Options for all Computers

Custom options are specific to the computer on which they were configured. However, XrayVision allows the computer-specific options to be set as the default options for all other computers using the software in a networked environment.

To specify the computer’s options as the default:

1. Select Tools > Options Management from the main menu and click on Set this computer’s options as the default options.

2. On all other computers, select Tools > Options Management from the main menu and click on Make this computer use the default options. The change will take effect once the software is restarted on these workstations.
5.7.1 Setting up a Toolbar as the Default for all Computers

A customized toolbar is specific to the computer on which it was configured. However, XrayVision allows the computer-specific toolbar to be set as the master for all other computers using the software in a networked environment.

To specify the computer’s options as the default:

1. Select **Tools > Options Management** from the main menu and click on **Set this computer’s toolbar as the default toolbar**.

2. On all other computers, select **Tools > Options Management** from the main menu and click on **Make this computer use the default toolbar**. The change will take effect once the software is restarted on these workstations.

5.7.2 Setting up a Toolbox as the Default for all Computers

A customized toolbox is specific to the computer it was configured on. However, XrayVision allows the computer-specific toolbox to be set as the master for all other computers using the software in a networked environment.

To specify the computer’s options as the default:

1. Select **Tools > Options Management** from the main menu and click on **Set this computer’s toolbox as the default toolbox**.

2. On all other computers, select **Tools > Options Management** from the main menu and click on **Make this computer use the default toolbox**. The change will take effect once the software is restarted on these workstations.
6 HARDWARE OPTIONS

The hardware options of the program allow users to adjust settings that are specific to the imaging devices that they use, for example sensors, phosphor plate scanners, etc. You can access the hardware options menu by selecting Tools > Hardware Options. The hardware preferences window will then display.

6.1 The Sensors Tab

- **‘Sensor Device Options’** – Sensor extensions (files ending in *.SED) are hardware-specific files that extend XrayVision’s image processing capabilities to acquire x-rays from different sensors. Any sensor extension is listed in this section. Double-click on any listed sensor to open and modify the specific sensor’s options, or select the extension in the list and click the “Options” button.

- **Prompt for tooth information before capture** – If this general option is enabled, the user will be prompted for tooth information before the sensor is prepared for X-ray exposure.

- **When capturing a layout, pause between sensor captures** - This option is useful when a sensor system times out too fast or if a certain sensor system needs more time to "reset itself" before it is prepared to capture the next tile in the layout.

- **Enable Audible Indicators** - This option enables an audible voice that will say "Sensor Ready" or "Sensor Failure" when interacting with the sensors. Users can select a male, female, or cartoon voice by clicking on the appropriate button. Although the imaging application provides default ‘sensor ready’ and ‘sensor failure’ WAV files, a user can configure their own by selecting the applicable browse buttons to locate and select a different file.
6.2 The Imaging Devices Tab

The Imaging Devices tab contains options for any installed imaging device extension (files ending in *.IDDLL). Most phosphor plate scanners and intraoral cameras use these extensions.

To adjust any hardware-specific option in this interface, simply double-click on the extension in the list, or highlight the extension and click the "Edit Options" button at the bottom of the window.

- **Select Video Device** – This option allows the user to decide which method of video capture will be utilized by the XrayVision program.

  - Direct Video – The Apteryx-native video extension. This option is used for USB and composite intraoral cameras.
  
  - Real-Time Video – This source captures video from a Video-for-Windows driver. This is an older method of video capture and is no longer supported by most video hardware.
  
  - Quick-Cam Video – This legacy option should only be utilized if the user has an actual quick cam that is not compatible with the Direct Video extension.
6.3 Direct Capture Devices

This tab contains options for any CT or 3D capturing hardwares that utilize an Apteryx Direct Capture extension (files ending with *.DCDLL).
6.4  TWAIN Devices

XrayVision is designed to find any Windows-compatible TWAIN device drivers that are installed on a computer. Most flatbed scanners use TWAIN drivers to send their scanned images to a PC. There are also numerous dental hardwares that do not have a direct integration with XrayVision, but can utilize a TWAIN driver to return an image to the software. This tab in the hardware options lists any TWAIN devices that are found on the system.
6.5 Foot Pedal Options

If a practice has a foot pedal that they utilize to acquire images, this tab allows them to enable foot pedal actions, as well as assign specific actions that the software should take when a pedal is pressed. Simply select an action from the Foot Pedal 1 or 2 drop-down menu to assign it to that pedal.